Back to Blog Posts

Upcoming PHP Requirement Changes

By Matt / June 2nd, 2016

Our next major update of WHMCS will require PHP 5.6 or later.

While this will be the minimum requirement, we strongly recommend using the latest available, stable releases of all software and extensions.

Why are we changing the minimum requirement?

PHP 5.5 reaches end of life next month. This means it will no longer be supported by PHP and perhaps more importantly, will not receive any further security updates. For that reason, we are encouraging all our users to upgrade as soon as possible.

In addition to that, raising the minimum requirement allows us to take advantage of advancements in the PHP language, as well as newer third party libraries and functionality that make developing and maintaining the product easier and more performant.

What do I do if I am running a version of PHP older than 5.6?

We recommend that you upgrade as soon as possible. If you are using a web hosting provider and not on a dedicated server for your WHMCS installation, you will want to contact your hosting provider and ask them how you can upgrade to PHP 5.6. Future versions of WHMCS will require PHP 5.6 as a minimum meaning you will be unable to upgrade until the server is upgraded to PHP 5.6 or later.

What about PHP 7.0?

We're already developing, running and testing WHMCS internally in PHP 7 environments. Within the last few weeks, Ioncube has released loaders that support PHP 7.0 under beta status. We continue to monitor and watch with interest the progress of Ioncube's loader development for PHP 7.0 and are committed to delivering WHMCS with support for PHP 7.0 as soon as the necessary Ioncube loaders are made available.

As always, if you have any questions or concerns, please feel free to reach out to our support team.

Liked this article? Share it